This is as much a note to myself as anything, but if you have recently tried to update a project that was using Lumen 5.1 to use Lumen 5.2, you might get an error that Illuminate\Foundation\Support\Providers\EventServiceProvider can no longer be found.

The problem is explicit in the error, thankfully: the class can no longer be found. The question then is, where has that file gone?




So, to fix in the issue, open app/Providers/EventServiceProvider.php and change use Laravel\Lumen\Providers\EventServiceProvider as ServiceProvider; to use Laravel\Lumen\Providers\EventServiceProvider as ServiceProvider; instead.

Problem solved!